0

I've tried installing the latest QGIS relaease on my Ubuntu according to the installation guide on the website (which has worked before).

wget -qO - https://qgis.org/downloads/qgis-2021.gpg.key | sudo gpg --no-default-keyring --keyring gnupg-ring:/etc/apt/trusted.gpg.d/qgis-archive.gpg --import

sudo chmod a+r /etc/apt/trusted.gpg.d/qgis-archive.gpg

I got this error code:

gpg: key 46B5721DBBD2996A: 1 signature not checked due to a missing key
gpg: key 46B5721DBBD2996A: "QGIS Archive Automatic Signing Key (2021) <qgis-developer@lists.osgeo.org>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1

When trying to install now, using:

sudo add-apt-repository "deb https://qgis.org/ubuntu $(lsb_release -c -s) main"

I get:

N: Skipping acquisition of configured file 'main/binary-i386/Packages', as repository 'https://qgis.org/ubuntu focal InRelease' doesn't support architecture 'i386'
N: Skipping acquisition of configured file 'universe/binary-i386/Packages', as repository 'http://miktex.org/download/ubuntu bionic InRelease' doesn't support architecture 'i386'
W: GPG error: http://packages.cloud.google.com/apt cloud-sdk InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY FEEA9169307EA071 NO_PUBKEY 8B57C5C2836F4BEB
E: The repository 'http://packages.cloud.google.com/apt cloud-sdk InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Doesn anyone have an idea what I could do? I tried deleting the old keys in sources.list, but it isn't working...

2 Answers 2

1

From what I can see it has nothing to do with QGIS but that Google repo for cloud-sdk. Remove or fix that and you should be good to go.

0

From Error adding qgis.org repository public key to apt keyring :

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-key 46B5721DBBD2996A

The key for the Google cloud-sdk is a different key, but the same error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.