0

enter image description here

I am attempting to add the Latitude and Longitude from a large (6000 row) .csv file into an ArcGIS Pro map. Only the "Latitude" field is appearing, and Longitude is no where to be found. I have made sure there are no spaces in the header field, in the lat/long data, and there are no blank spots or "NA" or anything of the like. There are also no letters in the lat/long fields, or any special characters besides . or - (in the longitude column, which may be why it's not appearing, but I would like to keep that format if possible/it worked in the past).

2
  • 1
    Have you checked that Longitude is a numeric field and has not inadvertently been set as text? If you open the attributes for that Standalone Table do you see Longitude there?
    – PolyGeo
    Feb 1, 2022 at 4:31
  • There are a few checks that can be made: Check if you can use the XY table to Points GP tool in ArcGIS Pro, check if you can copy the existing table into a new one for test. pro.arcgis.com/en/pro-app/latest/tool-reference/data-management/… Feb 1, 2022 at 9:20

1 Answer 1

1

I can no longer access this account (I was asilid), but I wanted to update that I fixed this issue by copying the lat/long into a new csv and removing any and all formatting, and that fixed it. I was getting an error when I opened attributes as well, and found that my initial csv was corrupted and wasn't saving any changes I was making.

Not the answer you're looking for? Browse other questions tagged or ask your own question.