I have an application using Geoserver 2.2, Openlayers 2.12 and Postgresql. I have been following the tutorial at: http://www.gistutor.com/openlayers/22-advanced-openlayers-tutorials/47-openlayers-wfs-t-using-a-geoserver-hosted-postgis-layer.html.

I have managed to display my vector data and I can see the save icon but not the modify, pan editing and the others. If i hover over their supposed locations, i can read their (pan, modify etc) titles and even pick and use them but i can't see the icons.

I tried to download the openlayers stable release and placed the theme/default/img folder in the root directory of the Geoserver but i still get no response. am using windows 7. I think the problem is with the path but i can't still figure it out.

I also tried to change the images to gif and jpeg but they still can't load.

  • Welcome to GIS SE! Can you post some of the code? It is rather hard to debug your problem without access to the code.
    – R.K.
    Nov 27, 2012 at 11:50

1 Answer 1


Use Firebug, Chrome's console or any other developer tool, and examine Net panel. You can see, from which path OpenLayers tries to access icons. Then you can correct path in OpenLayres or copy icons to correct directory.

  • the error that i get is the 404 not found, cant connect to localhost:8080/theme/default/img/editing tool bar.pgn. this goes for all the icons that am trying to upload. may be am not getting the path correctly. i put the theme file in the server side that has the index.html page. but this doesnt work for me.
    – ella
    Nov 27, 2012 at 11:25
  • I eventually tried to access the icons from a file and not the server, i followed an illustration given by a user in the above named tutorial by erasing all the url(../) and replacing them with url("theme/default/img/pan_on.png") i could see the icons from the file access but when i load from the localhost:8080, i could not see the icons. could it be an issue with the proxy in configuring the openlayers but then how comes i can hover over the supposed positions and see the titles and also use the tools but cannt see the icons.
    – ella
    Nov 29, 2012 at 8:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.