3

I'm having trouble using QGIS version 3.20 on Mac OS with a WMS-T layer.

The WMS service is available at https://ows.dea.ga.gov.au/wms. The specific layer I'm using is the DEA Land Cover layer, named ga_ls_landcover.

I can see QGIS picks up the temporal range in the UI, and I can enable the temporal controller, but using the debugging console shows the request, like below, which does not have the TIME parameter set, which means that only one date is being displayed.

https://ows.dea.ga.gov.au/wms?SERVICE=WMS&VERSION=1.3.0&REQUEST=GetMap&LAYERS=ga_ls_landcover&STYLES=level4&WIDTH=512&HEIGHT=512&FORMAT=image/png&CRS=EPSG:4326&DPI=72&MAP_RESOLUTION=72&FORMAT_OPTIONS=dpi:72&TRANSPARENT=TRUE&BBOX=-42.93147526198666242,147.33781129267094911,-42.89315192638898822,147.37613462826863042

What is the correct way to get QGIS to be passing the TIME parameter to the web server?

An image of the config in QGIS is shown below.

QGIS and WMS-T

2 Answers 2

0

I tested here with QGIS master. The layer properies I used are the defaults for temporal:

Layer Properties for Temporal

After that I can see the requests set the TIME parameter correctly as I move along the time slider in the temporal controller. One thing I can see in your screenshot is that you have not set the step size in the controller widget:

Step Size

With that set, you can see the subsequent requests to the service will include the time step:

enter image description here

enter image description here

1
  • Thanks, Tim, but I don't think that's it. I just checked in 3.22, and the issue doesn't happen. And I still have the "step" set as a default, like in my screenshot. Note that this seems to be what I'm experiencing: github.com/qgis/QGIS/issues/41504
    – Alex Leith
    Feb 8 at 12:03
0

It turns out that this is a bug, reported here.

I have tested with QGIS 3.22 and can confirm that it is fixed in this new version. The TIME parameter is passed through, and the temporal controller can be used to step through the years of the WMS service.

QGIS 3.22 and TIME parameter

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.