A question to the 3-D literate QGIS crowd: I downloaded .laz files from the French LiDAR data portal (https://geoservices.ign.fr/lidarhd#telechargement) and can't get it displayed in QGIS 3.22.3 (Windows 10). The file is loaded and the tile border appears, the corresponding "ept..." folders in the working directory are generated by untwine.exe but they stay empty and I can't visualize the data because there are no attributes to get hold of. There is no hint as to what could have gone wrong in the point cloud protocol, it simply stops and does nothing. When I'm loading the same data in Cloud Compare, the file renders perfectly. Did I miss a necessary step in data preparation?

1 Answer 1


In reality QGIS does not read the las/laz files directly. The number of points is too huge for this. When you load a las/laz file, QGIS converts it into entwine format using, a specific utility (hence the long loading time, especially on dense clouds).

The entwine format consists of a set of tiny laz tiles, which are loaded only when needed. If everything worked well, you should have several hundred (or even thousands) laz files in the ept-data subfolder (which you can open in cloudcompare and which have the same attributes as the original file). If this is not the case, the process did not work properly.

It is possible that the problem is due to entwine utilities. Try to generate entwine data manually from your initial laz (the process is explained here). You can then open the generated file in QGIS by selecting the file ept.json.

If it still doesn't work, it is possible that the problem comes from the data itself.

  • Thank you! Feeding it manually into entwine did take some time on my old machine, but it did the trick and the resulting data could be loaded and styled without further problems.
    – gisnogud
    Feb 11, 2022 at 12:33
  • 1
    So the problem must come from QGIS, it must not find entwine or its dependencies. Note that if you have downloaded several tiles, you can group them in the same entwine folder, it is not necessary to run entwine build for each tile.
    – Atm
    Feb 11, 2022 at 13:09
  • 2
    I found the root of the problem. If you've got a non-ASCII character or a space in your profile path, Entwine won't start. I just tried it on another machine, same configuration, other profile path - everything runs as it should. Again: Thank you for your tips, they helped me understand the workflow.
    – gisnogud
    Feb 11, 2022 at 14:40
  • Did anyone file that as a bug against QGIS or entwine?
    – til_b
    Feb 12, 2022 at 19:23
  • @til_b I think not.
    – Atm
    Feb 14, 2022 at 9:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.