2

I have been using the convex hull tool to create MCPs for various layers (containing location points). For some reason, this layer is not looking like the others and I can't figure out why. It's as if it isn't including all the features and is thus producing a shape not at all representative of the actual spread of points. I have checked the features and found no noticeable errors and I have even tried manually selecting all the features and using the "use selected features only" option when running the convex hull - this hasn't worked.

Am I missing something super basic that is messing up my MCP? I'm using QGIS version 3.1.

Convex hull MCP not including all points

6
  • 1
    Can you share your data? Feb 15, 2022 at 10:12
  • Perhaps you should try concave hull instead.
    – Gery
    Feb 15, 2022 at 18:08
  • @KadirŞahbaz I'm afraid don't know how
    – AJ Shiron
    Feb 16, 2022 at 1:31
  • @Gery okay, would you be able to tell/show me how to do that (i'm a bit of a qgis newbie)
    – AJ Shiron
    Feb 16, 2022 at 1:32
  • @AJShiron in QGIS go to Processes -> Toolbox and in the search box type "concave", it should appear under the tab "Vectorial geometry"
    – Gery
    Feb 16, 2022 at 3:20

1 Answer 1

1

I am getting an error for Convex Hull in QGIS 3.16. Try using the minimum bounding geometry tool from the Processing toolbox. Minimum bounding geometry has an option for generating a convex hull. This worked just fine.

Consider submitting a bug report to QGIS.

4
  • This is the method I used and it worked fine for all my other layers but for some reason it looks wacky for this one
    – AJ Shiron
    Feb 15, 2022 at 6:16
  • 1
    QGIS 3.16.x is EOL (END OF LIFE), so there is no point in reporting the bug.
    – pigreco
    Feb 15, 2022 at 8:04
  • @pigreco 3.16.16 is the current long term release version
    – JGH
    Feb 15, 2022 at 14:15
  • 1
    @JHG true, but until 02/18/2022
    – pigreco
    Feb 15, 2022 at 14:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.