1

I have this shapefile (https://1drv.ms/u/s!AqMcxdEHKstsmgi1C7FO_81px_mg?e=09f6Ze), and this is the content of .prj file:

GEOGCS["GCS_WGS_1984",DATUM["D_WGS_1984",SPHEROID["WGS_1984",6378137,298.257223563]],PRIMEM["Greenwich",0],UNIT["Degree",0.017453292519943295]]

But, when I load this shapefile on QGIS, it is not in the right place. I tried set layer CRS to 4326 and 4674, but it didn't change anything.

This shapefile is working fine, and I can load it on it's right geo place (https://1drv.ms/u/s!AqMcxdEHKstsmglhL4xaqSpwd6rl?e=eOtlT7). It is the place where the first shapefile should be.

3
  • 2
    As you asserted this is WGS84 geographic, EPSG:4326. Where does the data show up? What is the extent? There is a possibility that this data has been defined as the wrong CRS or that project-on-the-fly is turned off or impossible due to the project CRS being undefined or the transformation from WGS84 to the canvas CRS is not set. Commented Feb 18, 2022 at 1:01
  • 1
    I tried to download your shp file but the link asked for registration (also lots of advertisment links). You could use gdal to find our what is in it (eg. ogrinfo yourshp.shp -al), if you send me the shp files to [email protected] I can take a look at it.
    – Gery
    Commented Feb 18, 2022 at 3:04
  • Your download links don't look "safe". Maybe try WeTransfer or DropBox?
    – Pointdump
    Commented Feb 18, 2022 at 8:20

1 Answer 1

3

There are a few potential things happening here. In answer to your specific question - The coord system is indeed EPSG:4326. The real question you're asking though is - Why is it not showing in the correct spot.

Sounds like you have another shapefile as a reference for where it should go, so that it is a good start.

  1. Check your project settings. Under Options > CRS - check the settings there. To test properly, I would recommend setting it to 'Use a default CRS' when creating a new project. (and obviously set this to 4326). Create a new project. Load your data in.

  2. Lets also assume for a minute that the shapefile is not reading the prj file for whatever reason. Set your setting in options > CRS - 'CRS For Layers' and set it to 'Use Project CRS'. This will make the layer project in 4326.

(If the above works, then its possible your .prj is not linked to your shapefile. (check that the names match! check for spaces. Delete it and recreate it again etc. )

If the above has not resolved the issue, then this probably means the data was captured using a different coord system. Unfortunately without knowing where you are, I can't tell you the answer. However try this.

In your local area, there will be localised map grids. Trying setting the coord system of the data to one of those local grids. Only you can work this out sorry. For instance, I live in Perth, Western Australia. The local map grid is MGA50. You can use the http://epsg.io/ website to help you find some of these. Once you set the LAYER to this coord system, your other settings should be ok and the layer should reproject on the fly to the 'correct' location.

1
  • 1
    The data were stored in this shapefile using a differente coordinate system: EPSG:3857 WGS 84 / Pseudo-Mercator... I figure it out taking alook at the website you suggested. Thank you very much for the help. Commented Feb 18, 2022 at 11:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.