1

I have QGIS version 3.16.11

The problem is that newly created layers (outputs from the Graphical Modeller) are not added to the layouts of the atlas. Creating an atlas (export Atlas as images) is of course embedded in the same model.

Example:

I create a simple model in a Graphical Modeler. The input is a point layer added to the project. In Model we create a buffer and set style (Set style for vector layer). The result is added to the layers of the map canvas. Let's add an Atlas to the model. It will create image files with a view of each of the buffered points. Coverage layer are the original points from the project.

First run of the model:

The model creates a buffer layer and adds it to the map canvas with the correct style, but the Atlas graphic files have the original points only. Atlas did not draw the buffers that were just created.

Second run: (run one by one without closing the model or making any changes. The previous result of the action remains in map canvas): the model works correctly - it also adds the created buffers to the output graphic files. I have tried many Atlas settings but never succeeded with the first run. Atlas cannot ”see” the newly created layer. It works as if before its creation. I also tried to set up dependencies, but it failed.

How to resolve this problem ?

1 Answer 1

0

I just checked with a simple example with a buffer and a basemap and in the 3.36.0 it currently works on the first run.

1
  • As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Commented Apr 24 at 16:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.