1

I have got WMS working through this URL:

http://192.168.5.119:8080/geoserver/sentinel3/wms?service=WMS&request=GetCapabilities

But when I try this:

http://192.168.5.119:8080/geoserver/sentinel3/wms?service=WMTS&request=GetCapabilities

I'm getting this:

<ows:ExceptionReport version="1.0.0" xsi:schemaLocation="http://www.opengis.net/ows http://192.168.5.119:8080/geoserver/schemas/ows/1.0.0/owsExceptionReport.xsd">
   <ows:Exception exceptionCode="InvalidParameterValue" locator="service">
      <ows:ExceptionText>No service: ( WMTS )</ows:ExceptionText>
   </ows:Exception>
</ows:ExceptionReport>

This is the Workspace configuration:

enter image description here

2 Answers 2

2

The correct path is not documented anywhere in the GeoServer documents but I managed to guess it. The demo page of your GeoServer has a link to WMTS GetCapabilities:

http://localhost:8080/geoserver/gwc/service/wmts?REQUEST=GetCapabilities

BTW this GetCapabilities URL does not seem to be correct by the WMTS standard because it is lacking the mandatory parameter &SERVICE=WMTS.

The place to add the name of the workspace is after /geoserver/. Try this

http://192.168.5.119:8080/geoserver/sentinel3/gwc/service/wmts?service=WMTS&version=1.0.0&request=GetCapabilities

2

I was also searching for how to access the WMTS service and found them listed with version numbers on the main page of your Geoserver (http://localhost:8080/geoserver/web) with links (see screenshot).

The WMTS link takes you to something like this:
http://localhost:8080/geoserver/gwc/service/wmts?service=WMTS&version=1.1.1&request=GetCapabilities

Then for a specific workspace, you have to add the name between geoserver/ and /gwc, as user30184 wrote:
http://localhost:8080/geoserver/WORKSPACE/gwc/service/wmts?service=WMTS&version=1.1.1&request=GetCapabilities

This is at least for Geoserver version 2.22.1, not sure for any older versions.

Geoserver home page with links to the various services

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.