2

Background:

At 3.22.3 I have a slope raster (32-bit floating point, single-band tif) derived from a DTM. I display this using a discrete interpolation, with three value ranges: 0-20, 20-40, and 40-90 degrees. These three ranges are symbolized with blue, green, and red, respectively. However, I require that the blue color be displayed with 25% opacity, as shown in the screenshot below. Green and red have opacity = 100%.

enter image description here

Problem:

When displayed in a Print Layout, the blue color with the 25% opacity displays correctly in both the map and in the Legend Properties, screenshot below.

But note that the map legend patch does not honor the 25% opacity. Instead, a solid color is displayed.

There is a Github bug report with a similar problem, but it was closed without resolution two years ago.

There is also a SE GIS post from 4 years ago, again without resolution.

enter image description here

Question:

How to force legend patches to honor opacity settings?

3
  • 1
    Just tried, I reproduced it, I comment the QGIS issue with a GIF and ask to reopen. Commented Mar 1, 2022 at 19:21
  • I'm glad to see that its not just me, and appears to be a bug!
    – Stu Smith
    Commented Mar 1, 2022 at 19:27
  • 1
    New issue about this bug : github.com/qgis/QGIS/issues/47612 Commented Mar 2, 2022 at 17:23

0

Browse other questions tagged or ask your own question.