3

I’m new in this forum. I’m not a native English speaker and I’m not very familiar with all the GIS-specific terms. I’ve tried unsuccessfully to import data to QField on my iPad Pro.

I’m using a MacBook Pro, Mac OS monterey, 12.2.1 and QGis 3.4.7-Madeira with the qfieldsync extension and an iPad Pro, IOS 15.3.1 and the QField beta with TestFlight.

First I created a project (saved as .qgs with relative paths) with two layers, one polygon shapefile and one WMS aerial photograph (Google). Then I used the qfieldsync extension to prepare the “package” for QField. The folder created contained the file myProjektname.QField.qgs plus the components of my shapefile. Then I transferred the data to my iPad, opened qfield and selected the to open myProjektname.QField.qgs in QField. Then an error occurred. The shapefile couldn’t be imported and I’m supposed to check the QGIS configuration (see screenshot).

Also I’ve tried to import a more complex project that was prepared for QField by a professional. The same error as above occurred, while others with QField on Android an even with the beta for the Windows surface got file working.

Can anyone help me how to import editable shapes to QField on iOS, please?

enter image description here

1 Answer 1

3

As far as I am aware, there is no import option in QField iOS application yet. I am an Android user, so never came across this situation but I tested this on my wife's iPhone and was able to replicate this.

Even in terms of storage access, they have a documentation which lists only Android. Here is a reference to the document which you may keep a track of if things changes in near future and they somehow update the iOS application to add import feature:

https://docs.qfield.org/get-started/storage/

I wish there was an official line from them in the same documentation about iOS, but no luck there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.