0

I want to calculate a new field named "urbanisation_degree" based on data which I add earlier in the process. In a first step, I extract raster data to points using "Extract multi values to points". Then I add the new field "urbanisation_degree". But the "Calculate Field" tool does not list the previously added fields. What am I doing wrong?

Edit: Adding a second screenshot showing that the Calculate Field tool is still not ready to run after I removed the Add Field step. All preceding steps work fine and create the intended output.

modelbuilder screenshot

modelbuilder screenshot2

2
  • 1
    Try feeding the output of the extract values tool into a make feature layer tool which then feeds into your add field tool?
    – Hornbydd
    Feb 28 at 22:52
  • @Hornbydd Just tried this. The Make Feature Layer Tool does not show any field in the "Field Info" section nor does it pass the fields to the Calculate Field tool. Mar 1 at 21:27

1 Answer 1

0

It does not show up as an option because technically, it isn't added yet until you have run the model. Instead of adding a field and calculating it separately, just use the Calculate Field tool. The field name can be existing or new, so add the new field name you want in that box and the expression/code for the new field.

1
  • Thank you. I removed the Add Field step, but the Calculate Field tool stays greyed out and does not run. Any idea? Mar 13 at 10:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.