1

I have been using QField for a while now testing whether our team should switch over to it for data collection.

All was going well then we started getting really bad GPS errors while collecting lines. This is happening across 4 different Android devices.

While walking slowly, collecting the line, the 'blue GPS icon' quickly expands to a large blue circle, then QField puts a point 100 - 200 plus meters perpendicular.

I have many different layers involved, tried changing a bunch of settings, most of the layers have symbology and constraints but I also imported the layers ( layers originate from a PostGIS/PostgreSQL server) with absolutely no symbology/constraints and get the same thing. I Googled GPS/battery saver issues for Android tablets and nothing is working.

Has anybody encountered this before?

enter image description here

4
  • Does this happen always roughly at the same location or in the same condition ? if yes it's probably more bad reception of gps signal than QField. To check if the problem came from QField or not try to simultaneously record your path on a second similar device using another app
    – J.R
    Mar 1, 2022 at 17:29
  • Thanks I will try that. This all started last thursday, the day the conflict started..... This happens across 4 different devices 500 plus kilometers apart, ish.
    – sbec
    Mar 1, 2022 at 18:23
  • UPDATE: Setup adroid tablet to use esri collector, avenza ( free edition) and qfield. Collector and avenza collected line data with no problem, qfield was like the above photo but worse. Having said that, qfield works fine with a gnss arrow 100 antennae using the same originating data and project. Now I am thoroughly confused.
    – sbec
    Mar 1, 2022 at 21:26
  • Were you collecting using esri collector, avenza and qfield at the same time when qfield showed the problem and the other apps didn't? If so, that's weird. My initial thought was that you were seeing spikes because you get high-error WiFi locations every now and then mixed in with GPS locations - but I would expect that to affect all the applications. In case this is the problem you could try turning off WiFi, see if that gets rid of the problem.
    – Trams
    Mar 2, 2022 at 2:45

1 Answer 1

3

ISSUE SOLVED: After much trial and error what solved this issue using the internal GPS was to TURN OFF the improve accuracy with wifi scanning and bluetooth scanning. In a previous suggestion from Trams above, I did try turning off the wifi but did not solve the issue. Go to settings, location, look for a tab/box on the right of the screen that says improve accuracy, enter that tab and turn everything off. This along with going into airplane mode made the difference. I suspect that sometime in the last week, android did an update that the pre-existing qfield software code did not agree with anymore. That is just my guess, it's all working now with all original data and constraints. I suspect that when the improve accuracy is on the tablet quickly drops the GPS connection and has a quick scanning for any available wifi/bluetooth and when it finds none, then it reconnects to the GPS and continues. As far as using an external GNSS unit like the Arrow 100, it still continued working as normal and the crazy lines were never a problem. I will continue using the GNSS with the improved accuracy and wifi turned off but the bluetooth turned on. Qgis/Qfield is now ready to deploy to the field for data collection.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.