1

I am trying to create buffers around specific roads I am working with. I carried out the following steps:

  1. I highlighted all of the roads:

    enter image description here

  2. I set out to create a buffer zone.

    enter image description here

  3. The buffer was created.

    enter image description here

  4. I had to zoom out to see the buffer.

    enter image description here

    enter image description here

Does anyone know what I can do to resolve this issue?. You can download the file here: https://www.mediafire.com/file/teva16p3ol96vmw/File.qgz/file

5
  • 5
    Do your roads display at the correct location in front of the basemap? If not, do not set a wrong crs. Reproject your data instead. Then do the buffering again.
    – MrXsquared
    Mar 13, 2022 at 21:57
  • 3
    A few questions. 1: What projection is the map canvas in? 2: What projection is the data you are using in the buffer in? This looks like a projection issue. 3: Have you measured the buffer? Is it 10m across? Have you measured the distances on the road network, do they make sense? Is there a chance the data you have brought in is in mm, or some other unit of measure? Mar 13, 2022 at 21:59
  • Yes I had to change the canvas projection initially because when I opened the buffer menu it would give me the option of setting the distance in degrees and not in meters. I didn't even notice that it messed up the coordinates until I placed a basemap. Now the roads are mapped correctly. Currently. the when I right click the roads layer and go to source the CRS is set to 'ESPG:4326 - WGS 84'. In the buffer menu there is a warning sign next to 'distance' which reads "Distance is in geographic degrees. Consider re projecting to a projected local coordinate system for accurate results".
    – HamidBee
    Mar 13, 2022 at 22:10
  • I've attached the file above in the main question section in case anyone would like to have a better look at it.
    – HamidBee
    Mar 13, 2022 at 22:59
  • 1
    Your file attatchment did not realy work, you only packed the .qgz without the actual layer data. You need to upload the data as well. Mar 14, 2022 at 6:50

1 Answer 1

3

As far as I can tell from your project data, your roads are in EPSG 4326. Many tools, including the buffer tool, do not work very well or at all with degree data. Since your data seem to be localised, I would suggest you reproject them into e.g. a UTM system. You can do this using the tool Reproject Layer (Vector > Data Managment Tools > Reproject Layer) or by just saving the layer to a different system. For your region I would suggest EPSG 32631.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.