My task was to upload a CSV file to QGIS. The CSV contains location data. When I load a layer, what happens is that a layer appears that contains the correct attribute table, but the points don't appear on the map, as if the layer is empty. What is wrong?

The projection has been selected correctly.

https://www.google.de/maps/place/REDWOOD+Bar+Berlin/data=!4m5!3m4!1s0x47a851efbe7ebf51:0x50f61d33ca221aa3!8m2!3d52.531761!4d13.3944742,REDWOOD Bar Berlin,4.5,325,Cocktail bar,"Classic & creative cocktails in a tiny bar with artfully distressed walls, bare bulbs & quiet music. · Dine-in · Takeaway · Delivery","Bergstraße 25, 10115 Berlin, Germany","G9JV+PQ Berlin, Germany",redwoodbar.de,,Closed,Closed,Closed,6PM–2AM,6PM–2AM,Closed,Closed,Closed today,https://lh5.googleusercontent.com/p/AF1QipP1JaQMK3vQ4sybHCdRMEwGyYXNADdvyxtFf9ss=w408-h258-k-no,TRUE,"https://www.google.de/maps/search/bars+berlin/@52.4578962,13.4314092,12z/data=!3m1!4b1?authuser=0",2022-03-15T21:44:07.718Z,
https://www.google.de/maps/place/Gecco+Bar+Berlin/data=!4m5!3m4!1s0x47a850ff3ee0121b:0xc6d7dcbff5ca6e0b!8m2!3d52.5034468!4d13.3343668,Gecco Bar Berlin,4.3,455,Bar,"Cool pub with a clubby vibe in the evenings, known for house cocktails & underground music. · Dine-in · Takeaway · Delivery","Rankestraße 3, 10789 Berlin, Germany","G83M+9P Berlin, Germany",gecco-bar.de,+49 30 8822981,2PM–2AM,2PM–2AM,2PM–2AM,2PM–4AM,2PM–4AM,6PM–2AM,2PM–2AM,Open now  2PM–2AM,https://lh5.googleusercontent.com/p/AF1QipP03Ud0AsQc1BY7G17nO7fGsTK2-OsfFpQWHS2g=w408-h306-k-no,FALSE,"https://www.google.de/maps/search/bars+berlin/@52.4578962,13.4314092,12z/data=!3m1!4b1?authuser=0",2022-03-15T21:44:10.795Z,
https://www.google.de/maps/place/BonBon+Bar+Berlin/data=!4m5!3m4!1s0x47a851e4531387b7:0xb36284b6b9fc77c3!8m2!3d52.5297081!4d13.3996743,BonBon Bar Berlin,4.1,260,Bar,"Classic cocktails & DJ sets at a moody, contemporary bar with plush sofas & armchairs. · Dine-in · Takeaway · Delivery","Torstraße 133, 10119 Berlin, Germany","G9HX+VV Berlin, Germany",bonbonbar.de,+49 30 24628718,6PM–1AM,6PM–1AM,6PM–2AM,6PM–3AM,6PM–3AM,6PM–1AM,6PM–1AM,Open now  6PM–1AM,https://lh5.googleusercontent.com/p/AF1QipNiBzA0JRqfToKOHYvguD9zeqtU6dtE_wlc2lI1=w427-h240-k-no,TRUE,"https://www.google.de/maps/search/bars+berlin/@52.4578962,13.4314092,12z/data=!3m1!4b1?authuser=0",2022-03-15T21:44:13.785Z,
https://www.google.de/maps/place/My+Bar+ICI/data=!4m5!3m4!1s0x47a851e67bd37c7d:0xb78eda2dea5483ea!8m2!3d52.5272417!4d13.3974889,My Bar ICI,4.2,185,Bar,· Dine-in · Takeaway · Delivery,"Auguststraße 61, 10117 Berlin, Germany","G9GW+VX Berlin, Germany",,,3PM–2AM,3PM–2AM,3PM–3AM,3PM–3AM,3PM–12AM,3PM–2AM,3PM–2AM,Open now  3PM–2AM,https://lh5.googleusercontent.com/p/AF1QipPykNDTtUDJMxYRPjfhu_TJZ-eNpL2orhp8Hb8y=w426-h240-k-no,TRUE,"https://www.google.de/maps/search/bars+berlin/@52.4578962,13.4314092,12z/data=!3m1!4b1?authuser=0",2022-03-15T21:44:16.498Z,

enter image description here enter image description here


1 Answer 1


Your problem is an inconsistent projection setting.

You wrote "The projection has been set correctly", by which I think you meant "I set the projection in the Add Delimited text dialog to the same as that of my project, namely UTM Zone 33N". However, the data in the CSV file is not in UTM coordinates, it is in latitude/longitude. To avoid QGIS interpreting the coordinates incorrectly, you need to set the projectin in the import dialog to (probably) EPSG:4326, which is latitude/longitude in WGS 84.

Note QGIS does reprojection on the fly, so it is no problem for it to display your layer in EPSG:4326 while your project is using a different projection. But you have to tell it how to interpret the coordinates provided.

Editing to add: I'm diagnosing this on the basis of the dialog box image you added in the comments, where you've selected Latitude and Longitude as the coordinates. However, you've also posted a link to an .xls which is probably the same data as your .csv. That however has no longitude or latitude or any coordinates.

  • You were right! Thanks!
    – Anastasia
    Mar 31, 2022 at 11:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.