1

I am trying to transfer an FMW (FME workspace) script, using FME workbench 2020.2, from windows to linux (Redhat).

In the FMW-script there are several published parameters. Among them there are 2 parameters. One for our DTM-raster .vrt file (parameter name = "DTM_dataset") and one similar to our DSM .vrt file (parameter name = 'DSM_dataset'). I have tried giving the published parameters the path to these .vrt-files both manually writing them and using the "Open file browser" option.

edited addition: these published parameters are transferred through a workspacerunner to another FMW-script, which have the same published parameters.

the paths given to FME are like this:

# linux path
/path/to/vrt/file/DSM.vrt

In both cases, the Translation log, and our logfile gives us this message:

2022-03-28 10:36:45|   0.9|  0.0|ERROR |VRT_RASTER reader: dataset '<solidus>path<solidus>to<solidus>vrt<solidus>file<solidus>DSM.vrt' cannot be located.  Please ensure the dataset exists and is accessible

and the weird part:

If i don't use the published parameters, but instead write the DSM-path manually in each transformer in the second FMW-script, the script doesn't spit out this error.

1
  • Are you using a feature reader transformer or a standard reader? I've had issues with this version of FME using parameters in feature readers. But, admittedly, not with rasters. Is the parameter a text parameter or a file parameter?
    – Fezter
    Mar 29, 2022 at 1:05

1 Answer 1

0

I haven't completely got an explanation, but my theory is when the first FMW-script has to send its published parameters to the second FMW-script, something goes wrong.

I think it interprets the forward slashes ("/") as a special character, not as literal string.

A not-so-elegant solution is to convert the "solidus" back to forward slashes in the second script.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.