3

I recently created a PostGIS database in an instance of Google cloud SQL.

I can view the data fine and I don't get an error message when I enter editing mode but I am unable to edit any data either from the map or table view.

Oddly enough I can add a new feature with attributes but once added I can't edit it or delete it using QGIS menu tools.

Also odd that I can run DELETE and UPDATE queries in DB Manager just fine so I don't think it is a permissions problem on the database end. The problem seems to be with the QGIS tool itself.

QGIS version is 3.22 but I tried with 3.10 and same result.

PostgreSQL is version 13.5 and PostGIS is version 3.0

1 Answer 1

3

SOLVED: I am a bit embarrassed, when I migrated my data to the cloud the primary key info was not included. The pk column was but it was no longer constrained as the primary key. It never occurred to me to check since everything else seemed to be just fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.