1

Im trying to install Qgis (3.x) at debian SID (unstable) following official instrucions (https://www.qgis.org/en/site/forusers/alldownloads.html#debian-ubuntu ) Using sudo add-apt-repository "deb https://qgis.org/debian-ltr unstable main" to add the repository, and then sudo apt update && sudo apt install qgis qgis-plugin-grass -y apt show the folow message:

 qgis : Depends: libproj22 (>= 5.0.0) but not installable
        Depends: libqgis-3d3.22.4 but it won't install
        Depends: libqgis-analysis3.22.4 but it won't install
        Depends: libqgis-app3.22.4 but it won't install
        Depends: libqgis-core3.22.4 but it won't install
        Depends: libqgis-gui3.22.4 but it won't install
        Depends: python3-qgis (=1:3.22.4+99unstable) but won't install
        Depends: qgis-providers (= 1:3.22.4+99unstable) but will not install
 qgis-plugin-grass : Depends: qgis-provider-grass (= 1:3.22.4+99unstable) but will not install
                     Depends: grass787 but not installable  
                     Depends: libqgis-app3.22.4 but it won't install  
                     Depends: libqgis-core3.22.4 but it won't install
                     Depends: libqgis-gui3.22.4 but it won't install
                     Depends: libqgisgrass7-3.22.4 but won't install
E: Unable to fix problems, you kept (hold) broken packages.```
2
  • Maybe try sudo apt update then sudo apt autoremove, and then install QGIS?
    – GBG
    Mar 29, 2022 at 20:35
  • i tried it and didnt work... Mar 30, 2022 at 18:25

1 Answer 1

0

I fixed it reinstalling Debian from scratch.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.