2

I am working on a project in QGIS 3.22.5 and it has suddenly started ignoring all settings re: snapping and overlap. It doesn't matter how many times I toggle the settings on and off I cannot make it snap or disallow overlaps. Snapping tolerance is set to 12 pix. I am using the same settings on other projects and there is no problem. If anyone can suggest a solution that would be great! Snapshot of current snapping settings attached QGIS Snapping Settings

4
  • Please provide the exact settings, if possible as a cropped screenshot, as well as additional information on whether this behaviour appears for all layers and which kind of layers we're talking about.
    – Erik
    Mar 30, 2022 at 14:25
  • You have chosen Vertex/Segment/Area/... or something? It is possible to "unchoose" all of them
    – BERA
    Mar 30, 2022 at 14:41
  • Hi Erik, the snapping problem occurs for different polygon layers and snapping does not work within the same layer or between layers. The overlap (I am set to avoid overlap on active layer) problem is intermittent and only seems to work occasionally for small polygons. My project has 100 or so polygons, could this be a RAM issue? I can't attach a screen shot to this comment but will try and add one to a reply to my own question.
    – Ali C
    Mar 30, 2022 at 14:43
  • You're aware that you only snap to the layer your editing?
    – Erik
    Mar 30, 2022 at 14:58

1 Answer 1

3

You must make settings for what QGIS should snap to e.g. Vertices, Segments, Areas. As far as I can see, nothing is activated on your screenshot, so it can't work as have not defined any geometry that QGIS should snap to:

enter image description here

1
  • Thank you I think that has fixed my issue
    – Ali C
    Mar 30, 2022 at 15:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.