5

When packaging a QGIS project for QField using QFieldSync plugin, I get the following error:

Layer does not use UTF-8, but "windows-1252" encoding.Working with layers that do not use UTF-8 encoding might cause problems.It is highly recommended to convert them to UTF-8 encoded layers.

The file is then unavailable when opening the project in QField.

How do I convert the shapefile to UTF-8 encoding?

2
  • 1
    This was stopping me configuring projects for QField using QGIS 3.22 and QField 2.14, both via QFieldCloud and via cable. The problem has gone away now I have encoded the shp files at UTF-8.
    – Oisin
    Apr 12, 2022 at 17:49
  • There was this thread on the default encoding setting. gis.stackexchange.com/questions/381308/…
    – John
    Apr 12, 2022 at 17:59

1 Answer 1

3

Right click the layer - Export as, and specify the encoding

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.