On pgAdmin 4, geometry columns always show as huge lines:

enter image description here

So when I want to check the geometries inside Postgres I have to go all the way until the end of the line with a very small scroll bar:

enter image description here

That bothers me a little... Is there any way of forcing all columns or specific columns in a way that they won't show all the data that it has in each line when we use pgAdmin 4? I'd like to make it to be something as follows:

enter image description here

  • 6
    This has already been answered: stackoverflow.com/questions/68393713/…
    – hgb
    Apr 22, 2022 at 1:52
  • I couldnt vote to close as "duplicate", it is not possible for a duplicate to be on another site than gis.stackexchange.com. I agree it is on topic
    – BERA
    Apr 24, 2022 at 8:12

1 Answer 1


On the top left menu, go to "Files > Preferences" and then click the "Results grid" in the left column.

Change the "Maximum column width" to the desired value, here 200 pixels:

Screenshot from pgadmin4 version 6.8. Screenshot from pgadmin4 version 6.8.

Click the "Save" button.

Execute your query again to see the changes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.