3

I have a problem with all my saved .qgz projects. I always worked with layers in projects only as .txt files, not saving them as shapefile, because I can make changes in .txt files (eg. add more localities to visualize) and reload the changes right into the project without reloading new layers and redoing all changes in particular layer (colors/shape of dots,...).

Recently I found that there is no QGIS program in my computer (have no idea how that happened), so I installed it again (both versions: 3.24.1 and 3.24.2 have the same problem). From that time when I open my already done with previous version, or completely newly done project in a new version, I always receive the message, that all .txt layers, which are still saved at the same place in computer, are unavailable. If I try to repair the source, there are no .txt files in folders! But there definitely are still there! I can see them in File Explorer in the exactly same path as it is the source, but the program can not find it.

When I put the very same .txt file as a new layer again, everything is working, I can save the project, but after I close and reopen the procet, there is the unavailable layers again. This problem is only with layers coming from .txt files. All other .shp layers remain and work.

It is visible in the picture, that the path to the layer is in the folder ".../darlingi" (left), but in Handling the unavailable layers (right), there is no .txt file in this folder, however it should contain four .txt files. The printscreen are in Czech, but I assume it is no big problem as the program has same graphics.

enter image description here

3
  • Just wild guessing, but maybe qgis does not recognize txt files as a supported format. You could use csv files instead, thats nothing else than a textfile using separators such as comma or semicolon for fields. You can edit csv with every software that can handle txt.
    – MrXsquared
    Apr 28, 2022 at 16:09
  • If your text files are tab-delimited as per Excel's standard then I think you are experiencing a similar problem that I raised a question last month about here: gis.stackexchange.com/questions/427340/… My work-around was to declare it to be a delimited file but not specify any delimiter, then finding qgis correctly opened it. I suspect it is a bug but others might help out. Apr 29, 2022 at 0:15
  • Leigh Bettanay, thanks for advice, but for me, this is not working... If I uncheck the "tab" delimiter, qgis do not recognize the tab and work as if, there is only one column instead of many. It is now working for me only if I use .csv file. It is annoying, because I have all projects saved with .txt files, but at least I know it will be working in future. Maybe there is really a bug in some versions May 3, 2022 at 7:32

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.