1

I am trying to perform a spatial join between a very large polygon layer and a very large point layer in QGIS. I left the process running overnight but there does not appear to be any sign of progress. I thought it might be an issue with my CPU or RAM but when I open task manager QGIS is only using 266% of the CPU and the memory is only 35%.

Has anyone else experienced a similar problem and if so has anyone solved it?

3
  • 3
    What is "very large"? 266%? Do the layers have a spatial index? How complex are the polygons?
    – MrXsquared
    May 1 at 17:46
  • 1
    A bit more context could help understanding the problem.
    – Babel
    May 1 at 21:30
  • When I perform the spatial join it says there is no spatial index. The polygon layer is 396.25 MB and has a feature count of 136,903. The point layer is 58.44 MB and has a feature count of 95,174.
    – Ian Moffit
    May 2 at 5:18

1 Answer 1

1

I figured out the problem was that a software problem called docker was running in the background even though it was not saying so in task manager. Once I uninstalled it, the spatial join worked perfectly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.