Workin in QGIS, I have a shapefile called "protected areas" of Dominican Republic, that was digitized from topomaps 50k. Shapefile is projected to WGS84, 19N zone. My problem is that when I load openlayers, the limits of almost all protected areas, don't get aligned with openlayers. In the following image there is an example:Image 1

The limit of the protected area (in red) is the coastline; but the real coastline plotted in Openlayers (google satellite) doesn't align with my shapefile (this area has rocky coastline, that haven't changed since topo was made). There is a ca. 45m shift in the X axis, and ca. 50m in the Y axis. In the following image: Image showing Shift

the limit of the protected area is prefectly aligned with topomap (coastline, road, etc.). As I know, OpenLayers is projected using "Web Mercator". So, do I need to define a new CRS with transformation parameters between WGS84 19N and Web Mercator? I believed they use the same ellipsoidal reference, so I shouldn't need to define a transformation.

Any help would be appreciated.



  • To be clear, the SRID of your project is 3857, and the SRID of your shapefile is 32619? spatialreference.org/ref/epsg/32619/html
    – L_Holcombe
    Dec 3, 2012 at 23:34
  • When I check NAD27 UTM 19N coords versus WGS84 UTM 19N, I get offsets around 43 m in X and 80 m in Y. Could the shapefile be using NAD27 rather than WGS84? Web Mercator is based on WGS84 (more or less) and doesn't need a datum transformation so that shouldn't be an issue.
    – mkennedy
    Dec 4, 2012 at 0:24
  • Yes L_Holcombe, SRID of my project is 3857 (because OpenLayers switch to it automatically), and shapefile is 32619. Thanks mkennedy for the suggestion, but I thought that firstly, and forced shapefile to NAD27, but the result was worst. I'm pretty sure shapefiel was done using WGS84. Now I'm thinking this might be a problem of inaccuracy of the topomap, because in some areas coastline or roads from topomap aligns ok with openlayers, and in other areas they don't. Should I trust more in openlayers than in topomap?
    – Jose
    Dec 4, 2012 at 3:31
  • What was the projection and datum of the paper topomaps? Did you use the same coordinate system while georefrencing it? Dec 4, 2012 at 5:02
  • The projection of paper topomap was NAD27, and it was reprojected to WGS84. Maybe that was the mistake. I tried digitizing a new coastline from topo, keeping the same datum between topo, shape and project (NAD27, 19N). I see a little improvement in alignment, but not what I expected. Both files (topo and shape samples), can be downloaded from: link
    – Jose
    Dec 4, 2012 at 6:42

1 Answer 1


Offsets by around 100m are in most cases due to different datums used, that is +towgs84 parameter in proj string is different.

You get a list of projections when you enter 19N as filter in Qgis. You have to find the right one...

Paper maps may be older, so you should look for an older reference ellipsoid datum. The older datum should be used when digitizing.

EDIT: I found an interesting article on Dominican grids here: http://www.asprs.org/a/resources/grids/ (2005, December).

EDIT 2: An online resource for DomRep maps: http://www.lib.utexas.edu/maps/topo/dominican_republic/

The GeoPDFs can be converted to Geotiff with Gdal 1.10.0 latest builds. But the quality of cartography is rather poor. You have to live with that. Remember that 50 metres offset are just 1 mmm on a 50.000 topo map.

  • Thanks Andre. In my last comment you would see link for test files. If you need bigger ones, I can send them too. Hope to hear from you.
    – Jose
    Dec 4, 2012 at 6:44
  • NAD27 is a bit difficult: The towgs84 parameters vary for every point of the earth. Qgis uses a official US grid file for that, but that is only exact for the United States. And Dominican Republic is not covered by that. So it would be best to re-georeference your topo map by identifying remarkable points in the map and in Google Earth, saving the map in WGS:3857 (as GE uses), and then maybe reprojecting it to WGS84 UTM 19N to have real metres as map units.
    – AndreJ
    Dec 4, 2012 at 7:35
  • I just discovered that Google satellite tiles go banana when i try to digitize the coastline from them in higher zoomlevels. bing tiles are ok in every zoom level, and fit rather good to your shapefile and topo. Even better than the Geopdf I mentioned above. Loading the stuff in uDig, your coastline shapefile gets an offset of 150m to the south. Looks like they understand NAD27 datum different than Quantum GIS.
    – AndreJ
    Dec 4, 2012 at 16:09
  • Thanks Andre. I tried this: 1) digitizing directly over NAD27 topomap and reprojecting shapefile; 2) reprojecting topomap from NAD27 to WGS84 and digitizing there. In all cases, I used geocentrical transformation with the parameters suggested by EPSG (+towgs84=-3,142,183,0,0,0,0). I found those parameters consistently also in other sources. Results are the same: shapefile not aligned with Google OpenLayers. I also tried GeoPDF, but get the same result: misalignment. Finally, I also noticed that Google satellite tiles acts strangely when trying to digitize over them. Seems that we have a bug.
    – Jose
    Dec 4, 2012 at 18:48
  • Regarding to Grids and Datums document, from Mugnier (2005), I believe we have a problem in DR with the precision of our geodetic network that Google Satellite is unveiling. This problem should warn dominican government about the need of finding a solution to get a good transformation between datums.
    – Jose
    Dec 4, 2012 at 18:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.