3

I would like to have my categorized styling in the correct order.

When I select the "Categorized" style option, QGIS orders it quite randomly. The effect is next visible on our map. Since you don't have overlays that's fine. Otherwise, there is a problem, which I have now. I have two items appearing in the same place, and which style category is different. I used the offset option, but the best will be to show the bottom one (turquoise) on the top.

enter image description here

I moved the In-Line Splice Closures value above the Midspan OH value in my categorized list, but it seems to not work unfortunately. Is there any smart solution for this problem?

2 Answers 2

3

Use Control feature rendering order (see documentation) at the very bottom of the Layer Styling panel: Epxand Layer Rendering, check the box next to Control feature rendering order, click the A/Z icon and the define the field that defines the rendering order as well as ascending/descending.

If you need a custom order (not alphabetically), you might create a new attribute field for that purpose - like a field rendering_order with values from 1 to n.

enter image description here

0
2

For fine tuning of the rendering, you can use the symbol level and set the desired order. This setting, compared to @Babel easiest solution, lets you draw various part of a symbol at various zlevel (ex print polygon fill of a category below another one, but draw its boundary above it)

enter image description here

enter image description here

1
  • I used your solution and it doesn't work. Shall I use the attribute table for that?
    – Geographos
    Commented May 5, 2022 at 8:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.