2

I get the following error when running a CopyRows_Management with Python (ArcGIS 10.1):

ERROR 000732: Input Rows: Dataset \MyConnection.odc\MyTable does not exist or is not supported

Here is the script that the model builder exported.

# Import arcpy module
import arcpy

# Local variables:
MY_DATA = "Database Connections\\MyConnection.odc\\MyTable"
MY_DESTINATION = "C:\\GIS-Shared\\MyData\\MyGDB.gdb\MyTable"

# Process: Copy Rows
arcpy.CopyRows_management(MY_DATA, MY_DESTINATION, "")
  • 1
    Hi, maybe you could have a look at arcpy.testschemalock() and arcpy.Exists() to help out with the debugging process. – dango Dec 4 '12 at 7:51
1

Does your MyTable exist? Also, your MY_DESTINATION variable needs to point to a out table. Right now you have it just pointing to a geodatabase. See link below:

See out_table parameter here

| improve this answer | |
  • Sorry - typo on my part. MyTable does exist on the input side. What's strange is this script works in a 10.0 environment but does not work in a 10.1 environment. They made it more difficult to add an OleDB connection so I'm not sure what may have changed from a scripting perspective. However, this script was generated by the Model builder just to test that the concept still works. – Blake Blackwell Dec 4 '12 at 2:53
1

Is MyConnection.odc the server name. I got the same error and the reason for it is because I didn't add .sde extension behind my server name. Check your servername by looking at the server properties->Editor Tracking. The Realm: @ text field is usually the name you should use.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.