0

I have successfully requested Landsat data from the USGS S3 bucket by following the provided tutorial. Now I want to pull a raster directly into QGIS via the Data Source Manager.

I have set my AWS_ACCESS_KEY_ID and AWS_SECRET_ACCESS_KEY environment variables under Preferences > System > Environment, and configured my request as shown in the image below.

screenshot of QGIS Data Source Manager config modal

When I click the Add button, I get the error:

Unsupported Data Source: /vsis3/usgs-landsat/collection02/level-1/standard/oli-tirs/2022/027/030/LC08_L1TP_027030_20220213_20220222_02_T1/LC08_L1TP_027030_20220213_20220222_02_T1_B8.TIF is not a supported raster data source.

I believe my issue is that the request QGIS sends is missing the required x-amz-request-payer header, but I'm not sure how to add it in the UI. Does anyone know?

1 Answer 1

1

I was able to achieve this by setting the Gdal environment variable AWS_REQUEST_PAYER=requester in the same place as the others above.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.