3

I am using QGIS 3.16.10 Hannover. Whenever I activate a label it also shows a lot of rectangles around the label. Does any one know how to remove them?

enter image description here

1
  • 1
    Try the following: In the label settings, got to the tab Placement and deactivate Repeating labels. Go to the Tab Background and disable Draw background.
    – Babel
    May 9 at 14:29

1 Answer 1

6

These rectangle are probably "candidate position" (ie. emplacement the labelling engine consider while placing label, the placement engine choose the best candidate relative to your setting to avoid overlap).

To make then disappear you should go to the Placement engine setting (click on the cogwheel next to the label selector)

enter image description here

Then deselect the "Show candidates (for debugging)" checkbox

enter image description here

1
  • Fantastic that works. Thank you very much :-). May 10 at 7:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.