I have a QGIS project where I am importing various WFS layers from a number of sources. One layer (from one provider) is not displaying while all the other layers from various other providers do display. The layer loads, appears in the layers menu, can be categorized in Properties and opens in the attribute table, it just doesn't appear on the map.
This is the URL for it, please let me know if anybody can get it to display. https://factmaps.npd.no/arcgis/services/FactMaps_ogc/3_0_WGS84_z32/MapServer/WFSServer

I am using QGIS version 3.24.2-Tisler (installed yesterday from QGIS website download) on a Windows 10 machine. I have also tried the same WFS on my Mac, which also loads the layer but fails to display it.

I have tried importing the layer into a new project, no other exiting contend and it gives the following message. Zooming to layer doesn't help. Layer FactMaps_ogc_3_0_WGS84_z32:Pipelines: Layer extent reported by the server is not correct. You may need to zoom on layer and then zoom out to see all features

  • Have a similar message in an earlier version of QGIS
    – nmtoken
    Commented May 11, 2022 at 9:35

2 Answers 2



Shows (for example) for Pipelines an extent of

        <ows:LowerCorner>-9.55909168 50.85795702</ows:LowerCorner>
        <ows:UpperCorner>24.10958405 71.96255067</ows:UpperCorner>

If I do a GetFeature request for pipelines and load that in QGIS, then export to EPSG:4326

You can see that the actual layer extent, doesn't match the advertised one

calculated bounds

QGIS is correctly flagging an issue with the WFS.


I'm using QGIS 3.18.2. A bit slow but seems to work OK. enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.