0

I am moving a simple ModelBuilder model from ArcMap(where it works fine) to ArcGIS Pro. It is to iterate through a selection of fields and then make a feature layer to use to select against. I keep getting the error it cannot open the out put of the Iterate Row (see error below). I have also tried Iterate Row Selection with the same error.

Image of Model

Succeeded at Thursday, May 12, 2022 11:32:42 AM (Elapsed Time: 0.82 seconds)
Executing (Make Feature Layer): MakeFeatureLayer I_All_Indexes_Merged_backup_2019_2_GP_NUM All_Indexes_Merged_backup_20 # # "OBJECTID OBJECTID VISIBLE NONE;Shape Shape VISIBLE NONE;PageNumber PageNumber VISIBLE NONE;GroupId GroupId VISIBLE NONE;SeqId SeqId VISIBLE NONE;Previous Previous VISIBLE NONE;Next Next VISIBLE NONE;LeftPage LeftPage VISIBLE NONE;RightPage RightPage VISIBLE NONE;TopPage TopPage VISIBLE NONE;BottomPage BottomPage VISIBLE NONE;Angle Angle VISIBLE NONE;Scale Scale VISIBLE NONE;GP_NUM GP_NUM VISIBLE NONE;flipAngle flipAngle VISIBLE NONE;Shape_Leng Shape_Leng VISIBLE NONE;Shape_Length Shape_Length VISIBLE NONE;Shape_Area Shape_Area VISIBLE NONE"
Start Time: Thursday, May 12, 2022 11:32:42 AM
 ERROR 000229: Cannot open I_All_Indexes_Merged_backup_2019_2_GP_NUM
 Failed to execute (Make Feature Layer).
Failed at Thursday, May 12, 2022 11:32:42 AM (Elapsed Time: 0.12 seconds)
2

1 Answer 1

1

I switched out the Iterate Row to Iterate Feature Selection and that seems to have done the trick. I am still not sure why this would not work in Pro as it did in ArcMap but at least I can move forward now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.