3

Something seems to be wrong with the layout manager/export function, leading to some weird error that it misses exactly one line string (in this case: the number "6") in the finished PDF/picture. Tried various possible fixes, playing around with the settings in producing the PDF, exporting as picture, but to no avail. Any ideas what could be wrong here?

E: Using a larger offset was the solution!

Visible in layout manager:

Visible in the layout manager

The finished PDF or picture:

In the finished PDF

Label settings atm:

Label

7
  • 3
    Please provide the label settings.
    – Erik
    May 20, 2022 at 8:33
  • I have also tried changing the placement of the string, priority or changing text size Also checked for validity of the geometry itself, which sometimes leads to weirdness May 20, 2022 at 8:37
  • What happens if you change the number from "6" to "7"? May 20, 2022 at 8:46
  • @bugmenot123 still doesn't show... May 20, 2022 at 8:50
  • 4
    Did you try to check the "Show all labels for this layer (including colliding labels)" in the Rendering tab ? or the "Show all labels for all layers" in the Placement engine setting ?
    – J.R
    May 20, 2022 at 8:57

1 Answer 1

4

I think the offset of 0.1 millimeters that you are using at the moment might be too small, I tried with a random set of polygons using "Outside Polygons" as a Mode and 0.1 millimeters as the distance the same way you did and half of the polygon IDs (polygons with labels "1", "4" and "6" out of 7 in total) didn't show on the exported PDF map. I tried again with a distance of 1 millimeter and all polygon IDs now appear on the final map. Does that work for you using a bigger distance?

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.