1

I update QGis to 3.24.3, with this new version, QGIS update Qt library to 5.15.3.

Now when I run my PyQgis App, I have this error:

Cannot mix incompatible Qt library (5.15.3) with this library (5.15.2)

Any idea to resolve it?

1
  • Hmm, I have the exact same problem on Linux mint, based off 22.04 Ubuntu. The suggestion below doesn't work for me, It just deletes the bindings you need to run pyqgis
    – U2ros
    Apr 19, 2023 at 10:39

2 Answers 2

0

I resolve uninstalling this library:

pip uninstall pyqt5-qt5
0

I encountered the same error under Ubuntu 22.04, QGIS 3.22. In my case, I solved the problem by using pip3 to uninstall a different package:

sudo pip3 uninstall pyqt5

This is based on the bug report here and here.

I didn't find it necessary to reinstall any package using apt as the bug report says. After the pip3 uninstall, I can still successfully do:

from PyQt5.QtCore import *

It seems as if both apt and pip3 installed their own versions of pyqt5, and there is a version conflict.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.