0

I've been trying to extract some contour polylines from a clipped geotiff DEM. I've got the polylines, but in my efforts to clean them up, I keep running into a problem when I run Vector Geometry > Simplify (or SAGA > Line Simplification for that matter). My attempts to enter various different tolerance values haven't helped either. As shown in the image below, I just end up with long straight lines that run clear from one side of my area to the other.

enter image description here

3
  • 1
    What is the coordinate system of your DEM? If it is WGS 84 or some other geographic system with units in degrees, typical tolerance changes used for meter or feet map units won't make much of a difference and produce odd results. In that case use the warp tool to reproject your contours to UTM or some other projected coordinate system and then run a simplify. As an aside I generalize LiDAR dem contours using v.generalize with the Lang method in the GRASS tools.
    – johns
    May 24 at 17:50
  • Bingo, that did it. It was in NAD83 (4269). Reprojecting to a SPCS solved it. Thanks! May 24 at 18:03
  • @johns, please put your comment as a valid answer
    – Taras
    May 25 at 5:28

1 Answer 1

1

As requested by Taras: "What is the coordinate system of your DEM? If it is WGS 84 or some other geographic system with units in degrees, typical tolerance changes used for meter or feet map units won't make much of a difference and produce odd results. In that case use the warp tool to reproject your contours to UTM or some other projected coordinate system and then run a simplify. As an aside I generalize LiDAR dem contours using v.generalize with the Lang method in the GRASS tools."

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.