I am using the MergeShapes plugin with QGIS 1.8.0 on a Windows 7 computer. The issue I am having is when I perform a merge from a directory based on one geometry type, and then switch the geometry type to process a second time (ie: process all polygons in c:\Temp and then process lines in the same directory). This is a limitation when you need to preform multiple merges based on geometry. Any help would be appreciated. Below is the error from MergeShapes.

An error has occured while executing Python code:

Traceback (most recent call last): File "C:/Users/ryangarnett/.qgis//python/plugins\mergeshapes\mergeshapesdialog.py", line 141, in accept self.progressFiles.setRange( 0, self.inputFiles.count() ) AttributeError: 'NoneType' object has no attribute 'count'

Python version: 2.7.2 (default, Jun 12 2011, 15:08:59) [MSC v.1500 32 bit (Intel)]

QGIS version: 1.8.0-Lisboa Lisboa, 6416f38

Python path: ['C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./python', 'C:/Users/ryangarnett/.qgis//python', 'C:/Users/ryangarnett/.qgis//python/plugins', 'C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./python/plugins', 'C:\PROGRA~2\Quantum GIS Lisboa\bin\python27.zip', 'C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\DLLs', 'C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib', 'C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib\plat-win', 'C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib\lib-tk', 'C:\PROGRA~2\Quantum GIS Lisboa\apps\qgis\bin', 'C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27', 'C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib\site-packages', 'C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib\site-packages\PIL', 'C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib\site-packages\win32', 'C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib\site-packages\win32\lib', 'C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib\site-packages\Pythonwin', 'C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib\site-packages\wx-2.8-msw-unicode', 'C:\Users\ryangarnett\.qgis\python\plugins\qgis2kml', 'C:\Users\ryangarnett\.qgis\python\plugins\qgis2kml', '/usr/share/qgis/python', '~/.qgis/python', '.', 'C:\PROGRA~2\Quantum GIS Lisboa\apps\qgis\python\plugins\fTools\tools', '~/.qgis/python', '.']

  • Have you tried other plugins such as the Merge Shape Layer function in mmqgis or the even respective function in the Qgis vector menu? – Curlew Dec 5 '12 at 20:21
  • Yes, I have tried them, with the same issue. – Ryan Garnett Dec 5 '12 at 20:24
  • 2
    Does it work if you restart the plugin between processing polygons and lines? If this is reproducible, it's probably best to file a bug report. – underdark Dec 5 '12 at 20:54
  • Yes, that is what I have been doing. I as hoping there was an alternative. Maybe a ticket entry for this to be fixed for the next release? – Ryan Garnett Dec 5 '12 at 21:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.