3

Using QField on an Android Phone, I wanted to import a project created on QGIS 3.24, using QField sync plugin. I did this with earlier versions of QField, but with the newest version 2.1.4, it doesn't work like it used to.

I read these instructions to get the right folder location. I am able to correctly add the project and open it in QField: the point layer I want to visualize shows correctly.

However, the OpenStreetMap basemap, added as XYZ-tile in QGIS, seems to be saved in a fixed resolution. So zooming in and out, the basemap does not change at all.

I am confused as in earlier versions, I could easily use several XYZ tiles (OSM, Google maps etc.) in the same project. Now, Qfield sync plugin seems to expect a basemap that is saved as a raster in GPKG format. When I deactivate the basemap, I get just a white background, even if I activate on of the other layers based on XYZ-tiles (second screenshot below).

I, however, want to have a dynamic basemap, accessed online, that changes resolution as it was possible in earlier versions.

How to achieve that?

EDIT:

I realised that the problem is connected to a problem with CRS (see here for more details). The saved geopackage static raster basemap does not show in the same position as the dynamic XYZ-tiles basemap - both are way off and at completely different scales of each other.

Settings in QGIS enter image description here

Settings in Qfield: basemap is deactivated, OSM and Google Satellite layers activated. Still, backgound is empty: enter image description here

1 Answer 1

2

The problem was solved by de- and re-installing QField. The problem was indeed caused by a wrong geolocation - the imported file-based layers (vector and static raster basemap) were located completely off the map canvas that showed the XYZ-tiles and in a completely different scale.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.