0

Working with DEM rasters from TNM 3DEP elevation data and trying to create a percentage slope map in QGIS. I added my rasters and tried running both the gdal slope that allows for % slope and the regular Slope QGIS plugin which goes to degrees.

When I run the Gdal function my scale max is much larger than 100, while the regular QGIS slope plugin spits back 0-89.999 but says all my land is 90 degree slope.

My coordinate system is NAD83 for the DEMs and WGS 84 for coordinates. I cant seem to be able to find the z units to make sure they are the same as X,Y so the tool isnt comparing degrees to feet; . Somewhat new to QGIS as my ArcGIS license expired.

2
  • 1
    The advice in gdal.org/programs/gdaldem.html applies: For LatLong projections near the equator, where units of latitude and units of longitude are similar, elevation (z) units can be converted to be compatible by using scale=370400 (if elevation is in feet) or scale=111120 (if elevation is in meters). For locations not near the equator, it would be best to reproject your grid using gdalwarp before using gdaldem. BTW % slope can be over 100, it is the ratio of horizontal and vertical movement. 45 degrees slope is then 100%.
    – user30184
    Jun 15 at 21:37
  • Thanks, plugging in the scale for meters in the Zfactor field fixed my issue. Hopefully this helps someone in the future
    – user207315
    Jun 16 at 16:07

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.