0

I have a basic model in which I want to buffer a shapefile. I've got some spatial data that will always be included, but I'd like to have the option for the user to set a secondary shapefile as a parameter which, if it's set, the model merges with the other before buffering.

I thought that this would be simple with the "If data exists" tool like this:

enter image description here

This will work with the "optional shapefile" parameter blank if I try to run the model through the editor, but I've found that it won't if I try to run it through the geoproccessing window, when I click run model I get the message "Parameter is missing or invalid".

4
  • I created the first part of your model (if and merge), and I CAN run the model with a blank "optional shapefile". Nothing happens, but that is expected. Can you describe how you can't run the model with the parameter blank?
    – KHibma
    Jun 21 at 12:40
  • @KHibma I can also run the model in edit view while leaving the optional shapefile blank, but if I try to run the model through the Geoprocessing window when I click the button to run the model I get the error "Parameter is missing or invalid".
    – tom91
    Jun 21 at 12:55
  • That works for me. In the Catalog pane, can you right click your model, select properties and verify your input is set to optional (vs being required)?
    – KHibma
    Jun 21 at 14:15
  • I just checked and it is still optional for me, but I still get the "parameter is missing or invalid message". Also, next to the space in input the file path for the additional shapefile I have a red "X" with the error "000468 Input Shape types are not equal" but I assume that is just because it is blank at the moment.
    – tom91
    Jun 21 at 14:25

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.