3

Exporting a project with OSM as a base map for offline usage and importing everything in the device, the base map loads only partially as for the two projects in the following pic.

enter image description here

I tried to change the generation parameters (tile size,mupp) but I still get the same results (and worsening speed in case of high detail/big size values). Years ago I had similar problems with the QGIS print composer that were related to a slow connection, but it is definitely not the case now. Any other parameter I'm missing?

I'm using QGIS 3.22.7 on W10 and the latest QField/QFieldSync (but it happened also previously).

3 Answers 3

1

Not sure it works, but when setting the project properties, have you tried to set the OSM layer as Base Map?

Project > Properties > QField then select the QFieldCloud or Cable Export panel depending on your needs and set as in the image:

enter image description here

5
  • Thank you but unfortunately those are my actual settings...
    – Nico
    Commented Jul 4, 2022 at 9:38
  • Any other additional info about your settings?
    – HyPhens
    Commented Jul 14, 2022 at 14:48
  • nothing in particular more than the fact that, while packaging, I get a warning because some vector layers are not in UTF-8
    – Nico
    Commented Jul 15, 2022 at 8:41
  • Have you tried to create a different test project, maybe on a different device, just to see if it's a persistent issue?
    – HyPhens
    Commented Jul 15, 2022 at 11:27
  • it happens with all my projects both on my smartphones and my tablet
    – Nico
    Commented Jul 15, 2022 at 13:37
1

I you have other (unnecessary) offline maps like mbtiles or raster maps in *gpkg files in the project, try deleting them (just as the themes based on those) . Then configure the OSM base map based on a single layer (a xyz OpenStreetMap). In my experience it renders then fluently offline. I have the impression that other offline raster maps make the use of the base map more complicated... Perhaps this is also the case in your project(s).

1

After one year, I randomly stumbled upon the solution! It seems that the exported basemap is only the one visualised in the main map canvas. So I had to zoom to the biggest layer extent and then pack the project to see the basemap fully exported. It looks to me a weird behaviour but so it is. I hope this may help others!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.