0

I just got this problem where my screen in ArcMap has this constant "import arcpy" phrase in the middle of it. It happened after I ran a Python script, but I deleted everything related to it and it is still there. Closing the program and opening it again doesn't seem to solve the issue.

The script I ran:

import arcpy
from arcpy.sa import *
arcpy.CheckOutExtension("Spatial")
arcpy.env.workspace = "C:\\Users\\user\\OneDrive\\Documents\\ArcGIS\\ArcMap_Folder"
inRaster = "Slope_tif7.tif"
myRemapRange = RemapRange([[0, 3.99, 1], [4, 9.99, 2], [10, 15.99, 3], [16, 30.99, 4], [31, 60.99, 5], [61, 999999, 6]])
outReclassRR = Reclassify(inRaster, "VALUE", myRemapRange)
outReclassRR.save("C:\\Users\\user\\OneDrive\\Documents\\ArcGIS\\ArcMap_Folder\\reclass.tif")

Image of what it looks like: enter image description here

3
  • 2
    That looks like a text element so try selecting it or all graphics.
    – PolyGeo
    Jun 22 at 20:05
  • @PolyGeo Do you mean the Layers section in the left side of the screen? If so, I checked off all the elements there but the "import arcpy" still appears.
    – Darell
    Jun 23 at 14:10
  • Try both Layout View and Data View but I think there should be a Select All Grsphics option somewhere. Also, try searching the Zhelp for that.
    – PolyGeo
    Jun 23 at 20:14

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.