2

I'm using QGIS 3.22.4 then tried 3.22.7. I am using the clip tool. The input layer is a point(point) shapefile (verified in layer properties under information-geometry section). I have tried this with multiple different polygon overlay layers and all are giving me issues when running the tool if I try to save the result as a shapefile. Error message is "Attempt to write non-point (MULTIPOINT) geometry to point shapefile". On any of these I will get resulting points from the clip but only if I let it run as a temporary layer. Then I need to go and export the temporary layer to a shapefile however i have the same issue there with the same error message UNLESS I check the box for force-multi.

I've tried this with multiple file types including from a KMZ type Polygon(PolygonZ). I then exported the polygon that was originally a kmz into a shape file and regardless of the options I chose on export the resulting shapefile was still Polygon(MultiPolygon) and would produce the same errors. Then I tried running the multipart to singleparts tool on it and the resulting saved shapefile has a geometry type of Polygon(MultiPolygon) still. same result if I try to run the clip tool using that, I have to let it run as a temporary file, then export as a shapefile and choose force multi.

Am I missing something very obvious here?

Is the issue not with the polygon files?

I used to use the clip tool without any issues and now I cannot run anything.

4 Answers 4

1

I had the same issue. Could't do a simple clip. I belive issue was fixed in the QGIS version 3.28 (Firenze).

See the changelog and bugfixes: (Title: Fix some overlay algorithms output multipoint geometries but output layer is single point, causing insertion errors)

0

I believe i got this error recently also, only noticed it since upgrading to 3.22 and i havent done anything different to what i normally would. Maybe just an annoying bug.

I ran a Multipart to Singleparts on the point layer and then i was able to save it, its an annoying extra step, but it works.

1
  • The multipart to singlepart wasnt making in difference for mine but i'm glad i'm not the only one seeing the issue.
    – TRC
    Jun 23, 2022 at 16:39
0

I am having this issue. Although, I think I have it worse because I can't even save to a temporary layer. I have tried the conversion but the process only succeeds after selecting two topology types/vector layers that match. I just checked our older QGIS 2.18 installations and everything went along without a hitch.

0

The bug is known but the issue is still open today(okt.2022): https://github.com/qgis/QGIS/issues/49456

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.