3

I have two layers - the first is in 5514 (S-JTSK_Krovak_East_North; sr_0.shp) and the second in 2180 (ETRS_1989_Poland_CS92; pl.shp). I think the coordinate system of both layers is correct. I need to transform the layer coordinate system of the second layer from 2180 to 5514. I tried to do it using Qgis 3.2.3 (save as with new coordinate system 5514), and all possible transformations in Arcgis 10.5 to 5514 and also WGS84. I tried to use also Project tool or my own custom transformation as someone here advised me. However, layers still do not overlap, the shift between them is only about 0.5-2 metres or more, according to the selected transformation. I don't know if I am doing something wrong or where is the problem

Here you can find my layers: https://drive.google.com/file/d/1yM5XDZ6ndC9W1_dpS9A39HShwwW-gTzh/view?usp=sharing

2
  • 1
    Please confirm that your layer is first in the correct coordinate system. If it is not, projecting it will be incorrect. Second, check to make sure your second layer is in the correct coordinate system as well.
    – Binx
    Jun 23, 2022 at 19:25
  • Could please share your files or add some screen shots of the layers projection information.
    – Binx
    Jun 23, 2022 at 19:26

1 Answer 1

1

Thank you for providing your shapefiles. I did not get the custom transformation to work either, However, the project tool recommended this geographic transformation, and they aligned after running it:

enter image description here

Here is the geoprocessing history:

Project

Parameters

Input Dataset or Feature Class pl Output Dataset or Feature Class C:\Users\{user}\Documents\Temp\pl_project2 Output Coordinate System PROJCS["S-JTSK_Krovak_East_North",GEOGCS["GCS_S_JTSK",DATUM["D_S_JTSK",SPHEROID["Bessel_1841",6377397.155,299.1528128]],PRIMEM["Greenwich",0.0],UNIT["Degree",0.0174532925199433]],PROJECTION["Krovak"],PARAMETER["False_Easting",0.0],PARAMETER["False_Northing",0.0],PARAMETER["Pseudo_Standard_Parallel_1",78.5],PARAMETER["Scale_Factor",0.9999],PARAMETER["Azimuth",30.28813975277778],PARAMETER["Longitude_Of_Center",24.83333333333333],PARAMETER["Latitude_Of_Center",49.5],PARAMETER["X_Scale",-1.0],PARAMETER["Y_Scale",1.0],PARAMETER["XY_Plane_Rotation",90.0],UNIT["Meter",1.0]]

Geographic Transformation 'S_JTSK/05_To_ETRS_1989_1 + S_JTSK_To_S_JTSK/05_1'

Input Coordinate System PROJCS["ETRS_1989_Poland_CS92",GEOGCS["GCS_ETRS_1989",DATUM["D_ETRS_1989",SPHEROID["GRS_1980",6378137.0,298.257222101]],PRIMEM["Greenwich",0.0],UNIT["Degree",0.0174532925199433]],PROJECTION["Transverse_Mercator"],PARAMETER["False_Easting",500000.0],PARAMETER["False_Northing",-5300000.0],PARAMETER["Central_Meridian",19.0],PARAMETER["Scale_Factor",0.9993],PARAMETER["Latitude_Of_Origin",0.0],UNIT["Meter",1.0]] Preserve Shape NO_PRESERVE_SHAPE Maximum Offset Deviation
Vertical NO_VERTICAL

Messages Start Time: Tuesday, June 28, 2022 9:53:36 AM Succeeded at Tuesday, June 28, 2022 9:53:39 AM (Elapsed Time: 2.17 seconds)

Below is a comment that was unsuccessful:

I am not sure if the projection is possible, but I created a custom transformation from 2180 to 5514 using ESRI ArcGIS create custom transformation tool (https://pro.arcgis.com/en/pro-app/2.9/tool-reference/data-management/create-custom-geographic-transformation.htm). This is the result:

GEOGTRAN["To_5514_From_2180",GEOGCS["GCS_ETRS_1989",DATUM["D_ETRS_1989",SPHEROID["GRS_1980",6378137.0,298.257222101]],PRIMEM["Greenwich",0.0],UNIT["Degree",0.0174532925199433]],GEOGCS["GCS_S_JTSK",DATUM["D_S_JTSK",SPHEROID["Bessel_1841",6377397.155,299.1528128]],PRIMEM["Greenwich",0.0],UNIT["Degree",0.0174532925199433]],METHOD["Null"]]

This .gtf file was created at C:\Users\usernamefolder\AppData\Roaming\Esri\ArcGISPro\ArcToolbox\CustomTransformations. After I created the custom transformation on my windows machine. I added a shapefile to my arcgis pro project with the following projection(2180):

PROJCS["ETRS_1989_Poland_CS92",GEOGCS["GCS_ETRS_1989",DATUM["D_ETRS_1989",SPHEROID["GRS_1980",6378137.0,298.257222101]],PRIMEM["Greenwich",0.0],UNIT["Degree",0.0174532925199433]],PROJECTION["Transverse_Mercator"],PARAMETER["False_Easting",500000.0],PARAMETER["False_Northing",-5300000.0],PARAMETER["Central_Meridian",19.0],PARAMETER["Scale_Factor",0.9993],PARAMETER["Latitude_Of_Origin",0.0],UNIT["Meter",1.0]]

I copied the custom .gtf file to the same folder as my shapefile. Using the project tool in arcgis pro, i projected from 2180 to S-JTSK_Krovak_East_North (5514) without tool error. ArcGIS pro automatically populated my custom transformation file (To_5514_From_2180.gtf).

enter image description here

5
  • I tried transformation S_JTSK/05_To_ETRS_1989_1 + S_JTSK_To_S_JTSK/05_1, but it is always the same shift :(
    – zuzka
    Jun 30, 2022 at 14:33
  • Output coordinate system: PROJCS['S-JTSK_Krovak_East_North',GEOGCS['GCS_S_JTSK',DATUM['D_S_JTSK',SPHEROID['Bessel_1841',6377397.155,299.1528128]],PRIMEM['Greenwich',0.0],UNIT['Degree',0.0174532925199433]],PROJECTION['Krovak'],PARAMETER['False_Easting',0.0],PARAMETER['False_Northing',0.0],PARAMETER['Pseudo_Standard_Parallel_1',78.5],PARAMETER['Scale_Factor',0.9999],PARAMETER['Azimuth',30.28813975277778],PARAMETER['Longitude_Of_Center',24.83333333333333],PARAMETER['Latitude_Of_Center',49.5],PARAMETER['X_Scale',-1.0],PARAMETER['Y_Scale',1.0],PARAMETER['XY_Plane_Rotation',90.0],UNIT['Meter',1.0]]
    – zuzka
    Jun 30, 2022 at 14:34
  • Input coordinate system: PROJCS['ETRS_1989_Poland_CS92',GEOGCS['GCS_ETRS_1989',DATUM['D_ETRS_1989',SPHEROID['GRS_1980',6378137.0,298.257222101]],PRIMEM['Greenwich',0.0],UNIT['Degree',0.0174532925199433]],PROJECTION['Transverse_Mercator'],PARAMETER['False_Easting',500000.0],PARAMETER['False_Northing',-5300000.0],PARAMETER['Central_Meridian',19.0],PARAMETER['Scale_Factor',0.9993],PARAMETER['Latitude_Of_Origin',0.0],UNIT['Meter',1.0]] ,
    – zuzka
    Jun 30, 2022 at 14:35
  • Or could you share your transformed layer (pl) please, if it is really aligned to the layer in 5514 (sr)? It would be very helpful for me
    – zuzka
    Jun 30, 2022 at 14:46
  • After closer inspection, I see that you are correct. They are close to being aligned, but they are not exactly aligned. If I figure anything out, I will post an update Jul 1, 2022 at 15:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.