4

I am using ArcMap 10.0. I am trying to edit (and add) vertices in a polygon.

I start editing, (using "Edit Vertices" tool), and add many vertices in the polygon.

Then when I am done, I save the changes. But, the image gets simplified and I lose many of the additions!

Why is the editor deleting some vertices and simplifying the polygon?

  • When you say "save the changes" do you mean Finish Sketch or have you jumped straight to Save Edits? – PolyGeo Dec 7 '12 at 1:09
  • Either. I believe I have tried both. – P auritus Dec 7 '12 at 2:30
  • 1
    @P auritus, what type of layer are you editing (shapefile, geodatabase feature class)? Do you have any topology rules set? – artwork21 Dec 7 '12 at 4:01
  • 4
    What coordinate system (spatial ref) is the data frame in, and what is the layer's? It sounds like the xy tolerance or resolution of the data layer may be too big compared to how close together you're trying to place the new vertices. – mkennedy Dec 7 '12 at 17:29
  • Do you have large snapping tolerances set? – Dowlers Dec 7 '12 at 20:10
4

I believe mkennedy nailed it. If your polygons are being simplified, try drawing a much larger one. If that is successful, it means some of the vertexes in your smaller polygons are too close together because of data frame/layer coordinate system mismatch, and they are being snapped.

3

I am a GIS trainer in France and this problem happened to one of my students. The file he was editing on (process of georeferencing before) was not correct and the georeferencing tool was still open when the problem occurred. When referencing the image properly and closing the georef tool before editing the problem didn't appear anymore.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.