3

I have downloaded some SRTM topography data, which I've re-projected to a projected coordinate system and displayed as a hillshade. As seen in the attached screenshot, the product looks blocky, with vertical and gridlines visible across the map, even with the resampling set to bilinear or cubic. Is there a way to 'smooth' the hillshading to remove these lines?

enter image description here

1 Answer 1

6

Your screenshot depicts the classic blocky "herringbone" pattern resulting from applying a Nearest Neighbor resampling to raster elevation data. The solution is to instead apply either a Bilinear or Cubic resampling method. The Bilinear method does the least smoothing of the two, and generally solves the blocky pattern. However, I have come across a few cases where the additional smoothing created by the Cubic method is required to fully remove the pattern.

As a rule of thumb, I never use Nearest Neighbor resampling when using raster-based elevation data, and always use Nearest Neighbor when using imagery.

You mention that you unsuccessfully tried both Bilinear and Cubic. Although you didn't state when you applied it, I suspect that you meant only when displaying the reprojected SRTM, using Layer Styling. However, this may not be sufficient - you must review your entire workflow and identify any tool or process that has a Resampling option, making sure to avoid any Nearest Neighbor option. For example, the Warp (Reproject) tool has that option. Since you reprojected your data, I suspect that's where the error crept in:

enter image description here

1
  • Thank you Stu, changing the resampling method during the re-projection got rid of the "herringbone" pattern.
    – Saj
    Jun 27 at 13:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.