1

I am trying to put together a geoprocessing workflow in Python, and I've hit a stumbling block with sa.fill. When run as a standalone script, the tool produces a raster composed entirely of NoData values. If I run the same code in the Python window in ArcMap, a correctly filled raster is produced. My code snippet is:

outfill = sa.Fill(raster,"")
outfill.save(fill)
print "Sink fill complete."

I've tried copying my entire script into the Python window and adding it to a toolbox, but I get the following error in both cases:

Runtime error <type 'exceptions.EOFError'>: EOF when reading a line

The standalone script does not produce this error. It actually runs through all the steps without incident, but the output is useless as everything after the Fill step is based on NoData values.

Does anyone have any thoughts on this?

1

It appears to have been a service pack issue. Updating to the next service pack fixed the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.