1

I have been given a delimited text file with a series of polygons representing areas in the UK. I have a column labelled WKT_LatLong and the column contains the polygons. When I import the data it shows the polygons off the east coast of Africa and not in Torquay where I would expect it to be. The co-ordinates are backwards it seems, they are lat/long and QGIS seems to be reading them in as long/lat. I'm a QGIS n00b and can't find any documentation to fix this. Everything I read about WKT seems to show the co-ordinates as long/lat.

How can I convert this polygon:

POLYGON ((50.96831893 -1.72537935, 50.96840716 -1.72553119, 50.96826674 -1.72657135, 50.96757606 -1.72772179, .........)) //QGIS places this off the West coast of Africa

to:

POLYGON ((-1.72537935 50.96831893, -1.72553119 50.96840716..................)) //QGIS puts this where I would expect it.

There is a new polygon or multipolygon on each line and they're all different sizes.

I took one line and manually changed it with some Excel bodging but that's not going to work long term for all of the files.

Before I invest time wrangling with Python, I'm hoping someone will point me at a checkbox or util that does this for me.

2
  • 2
    50 degrees is the east coast of Africa, not the west. You are probably loading the file using the wrong projection so it reads degrees as if they were meters, so within 180 meters around 0;0 which is indeed near the west coast.
    – JGH
    Jul 15, 2022 at 18:50
  • Sorry I had meant east coast. Jul 19, 2022 at 15:14

1 Answer 1

3

Load the reversed layer as a delimited text layer, calculate a new wkt column with geom_to_wkt( flip_coordinates( $geometry)), export to a new csv file and import it back using the calculated wkt column for the geometry.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.