1

I managed to install OTB 8.0.1 in QGIS 3.22 on Mac using a comment on this community. However, the plugin is not working when I try to use "Segmentation". The process tells something like this:

dyld: Library not loaded: @rpath/libOTBCommandLine-8.0.1.dylib Referenced 
from: /Applications/OTB/OTB-8.0.1-Darwin64/bin/otbApplicationLauncherCommandLine
Reason: image not found

Does my image have a problem or did I install OTB wrongly?

4
  • 1
    How did you proceed, could you link the post that helped you with the installation process ? Also, it may be due to incompatibilities with newest hardware. Is your Mac Intel based, or M1 / ARM ?
    – vidlb
    Commented Jul 20, 2022 at 13:08
  • Hi there! My Mac is Intel based. The post that helped me was made by JDahlgreen and EcologyTom on 9th July 2021.gis.stackexchange.com/questions/15927/…
    – Chi
    Commented Aug 2, 2022 at 8:46
  • Did you activate the OTB plugin in the extension parameters ? Follow the best answer (not the green checked one) of the post you linked here. It is a built-in plugin you need to enable, similarly to GRASS
    – vidlb
    Commented Aug 3, 2022 at 9:13
  • But if you did activate it, I'd say (from your error message) that the path may be wrong. You need to double check that, following the docs on the official OTB website. Else you should ask your question on the official otb forum forum.orfeo-toolbox.org
    – vidlb
    Commented Aug 3, 2022 at 9:15

1 Answer 1

1

I didn't manage to use OTB on Mac. After all trials, I made a Windows installation on my Mac. OTB is working perfectly here!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.