1

I have installed QGIS 3.22. I opened the QGIS Desktop 3.22.9 and loaded two shapefiles as add layer/add vector layer. Loading was successful, but when displaying them it appears that the aspect ratio is wrong - so the width is too large with respect to the height.

The loaded shapefiles has been loaded from these links: https://ens.dk/sites/ens.dk/files/OlieGas/expappwells_20190821.zip and https://ens.dk/sites/ens.dk/files/OlieGas/blocks.zip

How can I load and display it correctly?

3
  • 1
    It looks fine to me. How are you seeing it? (screenshot please). Also, remember that aspect ratio depends on your map projection. Commented Jul 21, 2022 at 12:44
  • 2
    Odds are, it's displaying as requested; you just need to ask differently. Given that best security practice is "Don't download nothin'!" you really need to provide a screenshot and coordinate reference metadata from both the datafile(s) and map canvas.
    – Vince
    Commented Jul 21, 2022 at 12:59
  • They are possibly in coordinate system WGS84 (crs:4326), or your project crs is. Try setting a projected coordinate system for the project at the bottom right. For example I'm in Sweden so I can choose UTM zone 33N
    – Bera
    Commented Jul 24, 2022 at 7:59

1 Answer 1

7

First off, people are going to be suspicious you linking to .zips that they don't know, so it is unlikely that people will open those.

Secondly, it sounds like a projection issue. Going by the .dk domain I assume these shapefiles are to with Denmark, at higher latitudes the WGS84 projection (latitude and longitude) will look a bit squashed as you say, so find out what the correct projected coordinate system is for Denmark, and set the QGIS project to that coordinate system. That should display the shapefiles correctly.

3
  • 1
    There's nothing suspicious about zip files. They are not executables. You can look at their contents before deciding to open them or a file inside them. Commented Jul 21, 2022 at 13:23
  • superuser.com/questions/826746/… Commented Jul 22, 2022 at 22:42
  • Thank you for all your help. I am a new user and I had not set the right projection. Thanks Commented Jul 25, 2022 at 11:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.