0

I'm using ArcGIS Pro 3.0, though I only updated from 2.7.3 yesterday. I have ArcPy code to split large rasters into 4 equal corners: a top left, a top right, a bottom left, and a bottom right. Up until I updated, this code worked perfectly, but since the update, the tool has ignored the parameter to split the raster into columns and rows, and instead just splits it into columns.

Here is my code from before updating to 3.0:

#names and folders
nulltif2016 = r"G:\My Drive\work\Northern Animal Ecology Lab\sentineltif\evi2016null"
listnulltif2016 = glob.glob(nulltif2016 + r"\*.tif")
foldersplitcorners2016 = r"G:\My Drive\work\Northern Animal Ecology Lab\sentineltif\evi2016split"

#create name
for fp in listnulltif2016:
    fn = os.path.basename(fp)[:-4]
    date = fn[-8:]
    namesplitcorners2016 = "split" + date + "c"    
    #apply splitraster
    arcpy.management.SplitRaster(fp, foldersplitcorners2016, namesplitcorners2016, "NUMBER_OF_TILES", "TIFF", "", "2 2")

After the update, this produced 2 columns and 1 row, like a book. The code produced the same result when it was "2 4", which leads me to believe that it isn't reading the row parameter anymore.

How could this be fixed?

3
  • Bug reports should go to Esri Tech Support, where they can log, reproduce, submit, and track the defect.
    – Vince
    Jul 22 at 17:02
  • @Vince Thank you for the suggestion; I've done this, but was wondering if there was a workaround in case Esri's response took a long time.
    – Beck
    Jul 22 at 18:02
  • Have you tried running the SplitRaster tool manually on one raster to see if it works correctly? If it does, then go to your geoprocessing history, right click the result and copy as python code and look to see if there's any apparent difference to your script.
    – user2856
    Jul 23 at 4:39

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.