-1

I have few data in which ArcGIS Java Script version 2.6 and 2.8 is used & I am upgrading it to ver.3.0/3.1 and getting different errors like (Store error,Map display is blank etc.)

I searched on Google and ArcGIS Forum also following this article still getting an errors also I refereed few posts in which its mention that update the "store" but where should I exactly update?

4

in order to help solve your problems, we'd need to know what specific errors you are getting.

There are some minor changes from 2.x to 3.x versions of the JavaScript API, but by and large you can get away with using most of the same code.

The major changes I apply when converting from 2.x to a 3.x site are to update the dojo config module (as explained in the link you reference in your post).

Also, if upgrading to version 3.2, you need to include a reference to esri.css as mentioned in this page: What's new in 3.2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.