1

I am a new user of Geoserver. I have created a WFS and also could connect it with the QGIS WFS 2.0.0 Client plugin available now. But as like the default WFS link in that plugin I am not able to make a query in my service. Also the metadata is not coming for my service. Can anyone help me in this regards?

What do I actually have to do to make the stored queries and also to get metadata? Where to start doing that?

1 Answer 1

2

StoredQuery (Using a CreateStoredQuery POST Request)
How to add and use Stored Queries (in German language)
http://www.weichand.de/2012/04/22/wfs-2-0-stored-queries-beispiele/

Metadata How to add the MetadataURL for each FeatureType (in German language)
http://www.weichand.de/2012/08/26/metadatenviewer-fur-qgis-plugins-inspire-atom-client-wfs-2-0-client/

But please have look at: http://osgeo-org.1560.n6.nabble.com/GeoServer-2-2-INSPIRE-Download-Service-compatibility-td5008259.html

4
  • Hi Juergen, Thanks for your answer. I could make the stored query. but I am having the following error: java.lang.NullPointerException null -- in the WFS 2.0 QGIS plugin. can you tell me why I am having this type of error? Dec 18, 2012 at 22:53
  • I used Firefox Poster to make stored query. and also tried with your bbox query example. Dec 18, 2012 at 23:03
  • 1
    Probably this bug: jira.codehaus.org/browse/GEOS-5254 Dec 19, 2012 at 7:30
  • Yes Juergen, I have the same problem you told. But how can I overcome from this problem? Can you help me? I put the type name in the request url and I got the whole list of my feature. but the problem is I am always having the whole list of my feature. if I decrease my bounding box it also gives me whole features. and also still having same error: java.lang.NullPointerException null in WFS plugin QGIS Dec 19, 2012 at 13:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.